Openschoolproxy Forum

Forum für Fragen, Probleme und Anregungen zum OSP

Du bist nicht angemeldet.

#1 2018-02-25 16:44:27

Benedikt B
Administrator
Registriert: 2010-12-05
Beiträge: 249

OSP startet nicht mehr nach neustem Kernel update

Es scheint, als ob ein automatisches Kernel Update des OSP bei manchen Installationen zu Problemen führt (vielen Dank an Christian Hofmann von pc-future für den Problembericht und den Lösungsvorschlag). Betroffene Rechner starten nicht mehr. Die Fehlermeldung beim booten sieht in diesen Fällen ungefähr so aus:

error_msg.jpg

Falls das Problem auftritt, muss man beim Bootmenü den Eintrag "Advanced options for Ubuntu" auswählen und den älteren Kernel 4.4.0-112-generic auswählen. Danach muss man die folgenden Befehle ausführen:

sudo apt update
sudo apt upgrade -y
sudo reboot

Beim reboot wieder die Kernel-Version 4.4.0-112-generic unter dem "Advanced options for Ubuntu" Menü auswählen und dann die folgenden Befehle ausführen:

sudo mkdir -p ~/newkernel
cd newkernel
sudo wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16-rc2/linux-headers-4.16.0-041600rc2_4.16.0-041600rc2.201802190311_all.deb
sudo wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16-rc2/linux-headers-4.16.0-041600rc2-generic_4.16.0-041600rc2.201802190311_i386.deb
sudo wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.16-rc2/linux-image-4.16.0-041600rc2-generic_4.16.0-041600rc2.201802190311_i386.deb
sudo dpkg -i *.deb
sudo update-grub
sudo reboot

Danach sollte der OSP wieder wie gewohnt funktionieren.

Falls es zu Problemen kommt, lasst es mich einfach wissen.

Benedikt

Offline

#2 2018-09-11 10:09:18

PS
Mitglied
Registriert: 2013-04-25
Beiträge: 24

Re: OSP startet nicht mehr nach neustem Kernel update

Vielen Dank für die Lösung des Bootproblems mit defekten OSP an diech Benedikt und an Hr. Hofmann.

Bei mir haben die Reparaturbefehle tatsächlich wieder zu einem bootenden OSP geführt.

Dazu noch 3 Anmerkungen:

- es existerte keine Version 4.4.0-112, sonder nur 4.4.0-3xx, 4.4.0-3yy und eine 4.4.0-66
  -> die beiden 300er haben nicht funktioniert, mit der 66er hats dann geklappt
  Schade, dass man die langen Befehlszeilen nicht kopieren kann sondern mühselig abtippen muss...   hmm

- das Problem ist in einer anderen Installation in den vergangen Monaten bereits 2 mal aufgetreten, ich hatte da jeweils neu installiert 
   (in Ermangelung an ausreichenden Linux-Kenntnissen); Vermutlich war das da gleiche Problem.
  -> Meine Bitte wäre, ein aktualisiertes Installationsimage zur Verfügugn zu stellen, bei dem das Problem final behoben ist, das wäre super!

- Einige Zeit nach der Reparatur ist folgender Fehler aufgetreten
33796308tn.png

Nach einem weiteren Reboot läuft der OSP wieder.

Aussrdem zeigt die Konsole folgende Meldung an:

33796326wf.png

Gibt es hier was zu tun? Updates installieren?

Ansonsten: Mal wieder DANKE für dein Engagement, wir sind immer noch zufrieden mit dem OSP  smile

Beste Grüße
Peter

Offline

#3 2018-09-15 00:32:16

Benedikt B
Administrator
Registriert: 2010-12-05
Beiträge: 249

Re: OSP startet nicht mehr nach neustem Kernel update

Hallo Peter

Vielen Dank für die Rückmeldung. Die Kernel Versionen werden laufend geupdated so dass sich die Versionen von Zeit zu Zeit ändern. Gut zu wissen welche funktioniert, danke dir!

Die Befehlszeilen sollte man eigentlich kopieren können. Benutzt du einen physikalischen Rechner oder eine VM?

Was den fehler mit df0 angeht, eigentlich sollte der harmlos sein. Kannst du mal https://superuser.com/questions/141770/ … 0-sector-0 versuchen?

Und nein bitte nicht updaten wink! Security updates werden einmal pro Woche automatisch eingespielt und die anderen Updates sind feature updates. Bei feature updates kann es sein dass sich manche Konfigurationsdateien verändern und das würde den OSP unbenutzbar machen.

Beste Grüße

Benedikt

Offline

Fußzeile des Forums

Powered by FluxBB