Openschoolproxy Forum

Forum für Fragen, Probleme und Anregungen zum OSP

Du bist nicht angemeldet.

#1 2014-07-29 06:42:18

Bernhard
Mitglied
Registriert: 2014-07-24
Beiträge: 14

Firefox verlangt Passwort?

Wir hatten gestern das Problem, dass Firefox für den Zugriff über den Proxy nach einem Benutzernamen und Passwort gefragt hat. Im Internet gibts dazu einige Beiträge, aber unsere Lösung wird dort bisher nicht genannt:

Unser Linux-Rechner im Klassenzimmer war kein Domänenmitglied, deswegen verlangte der Proxy nach einer Identifizierung. Die Eingabe von regulären Zugangsdaten der Domäne (windowslogin/windowspasswort) brachte bei Linux keinen Erfolg. Hier wäre es wohl notwendig den Rechner der Domäne hinzuzufügen.

Bei unserem Windows-7-Lehrernotebook trat das gleiche Problem auf, da es auch kein Domänenmitglied war. Hier reichte allerdings die Eingabe von Zugangsdaten aus der Domäne um Zugriff zu bekommen.

Dies hat uns jetzt allerdings dazu veranlasst auf den OSP-Proxy auf IP-Basis zu wechseln um die Integration von BYOD zu erleichtern.

Hoffe, damit geholfen zu haben.

Viele Grüße

Bernhard

Beitrag geändert von Bernhard (2014-07-29 06:43:06)

Offline

#2 2017-07-24 17:44:49

Tomlin
Mitglied
Registriert: 2017-07-24
Beiträge: 11

Re: Firefox verlangt Passwort?

Ich muss das Thema nochmal aufgreifen: Wie lauten denn die Benutzernamen, wenn ein Gerät nicht Mitglied der Domäne ist? Viele unserer Schüler müssten mit dem Smartphone ins Internet.

Schöne Grüße
Thomas

Offline

#3 2017-07-24 18:06:44

Bernhard
Mitglied
Registriert: 2014-07-24
Beiträge: 14

Re: Firefox verlangt Passwort?

Hallo Thomas,
wir arbeiten immer noch auf IP-Basis. Soweit ich meinen Beitrag von damals verstehe: Es hat mit den Domänen-Zugangsdaten funktioniert mit denen die Schüler sich am Computer anmelden. Von einem beliebigen anderen Rechner.
Viele Grüße
Bernhard

Beitrag geändert von Bernhard (2017-07-24 18:07:15)

Offline

#4 2017-07-24 19:23:20

Benedikt B
Administrator
Registriert: 2010-12-05
Beiträge: 249

Re: Firefox verlangt Passwort?

Hallo Thomas

Wie genau der Login lautet hängt von der Domänenkonfiguration ab. Üblicherweise ist der Login:

DOMÄNENNAME\USERNAME

und das Passwort ist das normale Password des Users (unter Linux is es manchmal DOMÄNENNAME+USERNAME). Nicht alle Webbrowser unterstützen Authentifizierung am Proxy auf diese Art. Es sollte auf jeden Fall mit Internet Explorer und Edge funktionieren, es hat in der Vergangenheit auch mit Chrome funktioniert, ob es allerdings auch mit mobilem Chrome funktioniert weiß ich nicht. Ich würde dir raten, versuch es erstmal von einem Laptop aus mit Internet Explorer und wenn du weißt das der Login funktioniert, dann probiere es mit den anderen/Smortphone Browsern.

Noch ein Gedanke: Hast du auch geprüft dass du Rechner über das WLan zur Domäne hinzufügen kannst? Falls das nicht geht, könnte es sein, dass es eine Netzwerkbeschränkung für die AD Authentifizierung gibt.

Als Alternative könntet ihr euch auch Überlegen die IP-Variante des OSP für das W-Lan zu benutzen (mit strenger Filterung) und die AD Variante für die normalen Klassenräume. 

Beste Grüße

Benedikt

Offline

Fußzeile des Forums

Powered by FluxBB