Openschoolproxy Forum

Forum für Fragen, Probleme und Anregungen zum OSP

Du bist nicht angemeldet.

#1 2013-02-02 07:17:24

Thomas
Mitglied
Registriert: 2013-02-02
Beiträge: 3

Sperrseite für (fast) alle

Ich habe ein seltsames Problem mit dem OSP. Er läuft an meiner Schule (ca. 1000 User, AD) seit Monaten völlig problemlos. Wir verwenden den Proxy vor allem zur Protokollierung, deshalb sind alle Filter-Kategorien deaktiviert.

Seit gestern erhalten alle Benutzer nur noch die Sperrseite. Nach einem Neustart des OSP kommen einige (!) Benutzer eine Zeit lang ins Netz, die meisten aber nicht. Spätestens einige Stunden später kommt wieder keiner mehr durch.
Testhalber habe ich .de, .com und .org in die Whitelists für Schüler und Lehrer eingetragen, das hilft aber nichts.

Es gab in der letzten Zeit keinerlei Änderungen an der Konfiguration des OSP oder an den beiden Domänencontrollern.

Hat jemand eine Idee?

- Thomas

Offline

#2 2013-02-02 23:54:50

Benedikt B
Administrator
Registriert: 2010-12-05
Beiträge: 249

Re: Sperrseite für (fast) alle

Hallo Thomas

Was sagen die Serverstatistiken zur Festplattenausnutzung (Inodes und freier Speicher)? Gibts da irgendeine Linie in hohen Bereichen (über 90%)? Und falls ja, welche?

Viele Grüße

Benedikt

Offline

#3 2013-02-03 08:01:30

Thomas
Mitglied
Registriert: 2013-02-02
Beiträge: 3

Re: Sperrseite für (fast) alle

Hallo Benedikt,

an so etwas habe ich auch schon gedacht. Das squid access.log war 4GB groß, ich habe es am Freitag gzippt, danach ging es für ein paar Minuten wieder, aber kurz darauf beschwerten sich schon wieder Kollegen. Im Moment (von daheim) scheint alles zu funktionieren, aber ich habe nur eine Handvoll Accounts zum Testen - ob es wirklich wieder funktioniert, wird sich am Montag zeigen. Wenn es noch Probleme gibt, melde ich mich wieder.

Die inode-Auslastung liegt auf / und /var bei ca. 50%, /var war vor dem zippen des access.log ca. 80% voll.

Vielen Dank für die schnelle Hilfe und den ganzen OSP.

Thomas

Offline

#4 2013-02-05 07:14:38

bbs-d-admin
Mitglied
Registriert: 2012-05-21
Beiträge: 5

Re: Sperrseite für (fast) alle

Hallo Benedikt.
Bei uns ist es seit dem 04.02. das gleiche Problem. Ich habe versucht die Blacklist manuell zu updaten, dann erscheint folgendes.
Starting Blacklist upgrade

--2013-02-05 07:48:25--  http://www.shallalist.de/Downloads/shallalist.tar.gz
Auflösen des Hostnamen www.shallalist.de... 78.47.242.85
Verbindungsaufbau zu www.shallalist.de|78.47.242.85|:80... verbunden.
HTTP-Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 9912156 (9,5M) [application/x-tar]
In »/tmp/shallalist.tar.gz« speichern.

100%[======================================>] 9.912.156   1,61M/s   in 6,1s

2013-02-05 07:48:32 (1,56 MB/s) - »/tmp/shallalist.tar.gz« gespeichert [9912156/9912156]

Entpacke Dateien ...

Hole neue Version der mal_expressions Datei ...

fatal: read error: Connection timed out
Lege Url/Domain Datenbanken an, dies kann einige Zeit dauern ...

chmod: fehlender Operand nach â600â
âchmod --helpâ gibt weitere Informationen.
chmod: fehlender Operand nach â600â
âchmod --helpâ gibt weitere Informationen.
Squid already running, reconfiguring ...
Finished Blacklist upgrade


Ansonsten habe ich jetzt schon alle Haken bei den Contents entfernt und auf speichern gedrückt.
Dies führt dazu das kurzfristig scheinbar wieder alles funktioniert. Aber dann kommen immer wieder
einige und sagen, das sie nur die Sperrseite bekommen.
Ich kann mich erinnern, das vor ca. 3  Wochen schon ein paar Kollegen darüber klagten,
aber damals konte ich das nicht nachvollziehen.
Vielleicht kannst Du ja helfen. Das wäre SUPER.
Bei Bedarf würde ich Dir einen Puttyzugang zum Proxy öffnen.
Viele Grüße aus Dud.
Albert

Beitrag geändert von bbs-d-admin (2013-02-05 07:31:26)

Offline

#5 2013-02-05 07:52:14

Thomas
Mitglied
Registriert: 2013-02-02
Beiträge: 3

Re: Sperrseite für (fast) alle

Hallo,

bei uns funktioniert zur Zeit wieder alles.

Die Fehlermeldung mit dem chmod kam bei mir auch, nachdem ich testhalber ein "sudo osp-update -a" durchgeführt habe.

Viele Grüße
Thomas

Offline

#6 2013-02-05 12:07:56

Daniel D
Mitglied
Registriert: 2013-02-05
Beiträge: 5

Re: Sperrseite für (fast) alle

Hallo,

ich habe letzte Woche bei einem unserer Kunden den osp implementiert. Für ein paar Stunden läuft es einwandfrei, doch dann bekommt man bei allen Seiten (auch google.de) nur noch die Sperrseite. Sobald man in der Web-Admin-Oberfläche einfach auf "Änderungen übernehmen" (auch ohne Anderungen vorzunehmen) klickt, funktioniert es wieder für ein bis zwei Stunden. Genauso, wie nach einem Neustart des Proxys. Dieses Verhalten bekommen die Lehrer, sowie auch die Schüler.

Hintergrund:

installiert auf Windows Server 2008 R2 HyperV als virtuelle Maschine
HDD-Größe 40 GB (4 werden derzeit verwendet, 36 somit frei)
RAM 2 GB (981,92 mb unused)
OSP-Version 2.01

Ich hoffe es kann geholfen werden :-)
Für weitere benötigte Infos, einfach fragen :-)

Gruß
Daniel

Beitrag geändert von Daniel D (2013-02-05 13:40:14)

Offline

#7 2013-02-05 21:27:28

Benedikt B
Administrator
Registriert: 2010-12-05
Beiträge: 249

Re: Sperrseite für (fast) alle

Hallo Daniel

Sorry, dass du von diesem Bug betroffen bist. Dass ist ein Problem, dass bei der Kommunikation zwischen squid und dem AD auftritt und liegt vermutlich an einem script, dass mit der ntlm Implementierung der neueren WindowsServer nicht zuverlässig zurechtkommt. Bei manchen Schulen tritt das alle paar Stunden auf (wie bei dir), bei anderen nur einmal in der Woche/Monat. Der Bug ist unglaublich schwer zu troubleshooten.

Du einzige was du im Augenblick probieren kannst, ist ein system-update gefolgt von einer Neuconfiguration:

sudo apt-get update
sudo apt-get upgrade
sudo osp-update -e
sudo osp-update -a
sudo osp-setup

Derzeit arbeite ich an der 3.0 Version des OSP, der auf ubuntu 12.04, einer neuen squid Major-Version, sowie einem aktuelleren samba Version basiert. Damit sollte das Problem dann auch gelöst sein. Diese Version werde ich wohl Ende März veröffentlichen.

Wenn also obiges Vorgehen nicht hilft, dann würde ich übergangsweise bis Ende März auf die IP-Variante wechseln und dann die 3.0 AD Version installieren.

Sorry für die entstandenen Umstände und viele Grüße

Benedikt

Offline

#8 2013-02-05 21:37:03

Benedikt B
Administrator
Registriert: 2010-12-05
Beiträge: 249

Re: Sperrseite für (fast) alle

Hallo Albert

Die Fehlermeldung mit dem chmod ist ganz normal und hat keine Auswirkungen.

Zum Sperrseitenproblem: Ich würde ebenfalls das im vorherigen post beschriebene System-Update probieren. Falls dass nicht hilft, ein temporärer Wechsel auf die IP-Variante und Ende März dann auf die 3.0 Version. Wenn ich die genaue Problemuhrsache kennen würde, könnte ich gezielt etwas dazu unternehmen. Nur leider konnte ich den Bug bisher bei mir nicht reproduzieren.

Sorry, aber derzeit kenne ich keine sichere Methode das Problem zu beseitigen.

Benedikt

Offline

#9 2013-02-06 09:30:42

Daniel D
Mitglied
Registriert: 2013-02-05
Beiträge: 5

Re: Sperrseite für (fast) alle

Hallo Benedikt,

danke für die schnelle Antwort. Ich habe deine Befehle ausgeführt und werde jetzt abwarten. Temporär würde ich dann bis zum neuen Release auf die IP-Variante ausweichen.

Viele Grüße
Daniel

Offline

Fußzeile des Forums

Powered by FluxBB