Openschoolproxy Forum

Forum für Fragen, Probleme und Anregungen zum OSP

Du bist nicht angemeldet.

#1 2011-12-03 19:33:45

llg
Mitglied
Registriert: 2011-12-03
Beiträge: 2

OSP vergisst AD-Daten

Hallo,

ich habe seit etwa zwei Monaten den OSP installiert und war begeistert, wie einfach, reibungslos und schnell das ging.
Leider tritt immer wieder das Problem auf, dass ich den OSP neu starten muss, wenn ein Domänenserver neu startet (das gilt sowohl für den ersten Server als auch für den zweiten Server, der so konfiguriert ist, dass er die Anmeldungen entgegennimmt, wenn der erste ausfällt), da der OSP dann beim Öffnen eines Browsers immer nach einer Benutzerkennung fragt.
Es hilft dann aber auch nicht die Benutzerdaten (Benutzername und Kennwort) einzugeben. Offensichtlich "vergisst" der OSP die AD-Daten.

Für Hilfe wäre ich sehr dankbar.

Viele Grüße

llg

Offline

#2 2011-12-03 22:24:20

Benedikt B
Administrator
Registriert: 2010-12-05
Beiträge: 249

Re: OSP vergisst AD-Daten

Hallo llg

Ui, interressant was es alles fuer Probleme mit Domaincontrollern geben kann. Solch einen Fall hatte ich bisher noch nicht ;-)

Ich nehme an, eure Server starten immer zu festgelegten Zeiten neu? Der einfachste Fix waere in diesem Falle, den OSP automatisch im Anschluss daran neu starten zu lassen. Diese Loesung waere ein Befehl auf der Konsole und sehr schnell erledigt.

Wenn wir das Problem von Grund auf beseitigen sollen braeuchte ich einige Infos und du muesstest einige Befehle zum Testen fuer mich ausfuehren. Damit ich weiss, wie ausfuehrlich ich diese beschreiben soll, waere es gut fuer mich zu wissen, wieviel Erfahrung du mit Linux hast.

Es hilft dann aber auch nicht die Benutzerdaten (Benutzername und Kennwort) einzugeben. Offensichtlich "vergisst" der OSP die AD-Daten.

Vergessen ist fast zutreffend. Die Symptome deuten darauf hin, dass der OSP die Verbindung zum AD verliert und nicht wieder neu aufbaut.

Viele Gruesse

Benedikt

Offline

#3 2011-12-04 19:22:13

llg
Mitglied
Registriert: 2011-12-03
Beiträge: 2

Re: OSP vergisst AD-Daten

Hallo Benedikt,

im Normalfall werden unsere Server nicht heruntergefahren. Leider gab es in letzter Zeit aber Probleme, so dass immer wieder ein Neustart notwendig war. Aber auch bei Updates führt der Server manchmal selbständig einen Neustart durch.
Sehr gerne würde ich dem Verhalten des OSP auf den Grund gehen. Meine Linux-Kenntnisse würde ich so mittelmäßig einstufen, also lass es uns einfach probieren.

Vielen Dank schon einmal für deine Bemühungen und deine Hilfe.

Viele Grüsse

llg

Offline

#4 2011-12-04 19:54:51

Benedikt B
Administrator
Registriert: 2010-12-05
Beiträge: 249

Re: OSP vergisst AD-Daten

Hallo llg

Sehr gerne, dass ist auch mir lieber. Logge dich am besten per ssh auf dem OSP ein. Von einem Windows-Rechner aus geht das mittels putty (http://www.chiark.greenend.org.uk/~sgta … nload.html).

Um dem Problem auf dem Grund zu gehen, braeuchte ich die Ausgabe folgender Befehle nachdem einer der Windows Server neu gestartet ist (und das Problem auftritt):

sudo wbinfo -t
sudo wbinfo -g
sudo net ads testjoin
sudo tail -n 50 /var/log/samba/log.smbd
sudo tail -n 50 /var/log/samba/log.nmbd
sudo tail -n 50 /var/log/samba/log.winbindd
sudo tail -n 50 /var/log/samba/log.wb-SHORT_DOMAIN_NAME (wobei SHORT_DOMAIN_NAME der Name deiner Domaene ist. Findest du am besten durch ein vorhergehendes "ls" raus)
sudo tail -n 50 /var/log/squid/access.log
sudo tail -n 50 /var/log/squid/cache.log
sudo ls -ahl /var/run/samba/winbindd_privileged/

Sind ne Menge Befehle mit ner Menge Output. Waere klasse, wenn du die Ausgabe copy&pastest und als E-Mail an die Adresse schickst, die ich dir soeben per PN geschrieben habe.

Viele Grüsse

Benedikt

Offline

#5 2012-05-21 09:25:37

bbs-d-admin
Mitglied
Registriert: 2012-05-21
Beiträge: 5

Re: OSP vergisst AD-Daten

Ich habe genau das gleiche Problem, aber keine Lösung.
Immer wenn der OSP neu gestartet ist kennt er die
Domäne nicht mehr.

Gibt es mitlerweile eine Lösung ?

Ich würde mich freuen, da ich im Moment nach einer Lösung suche
den Internetverkehr in unserer Schule zu regeln.

MfG
A. N.  smile

PS: Die Maschine OSP-SERVER ist nach wie vor in der Computerliste des ADs.
Sobald man das AD-Integrationssetup neu ausgeführt hat funktioniert alles wieder.

Beitrag geändert von bbs-d-admin (2012-05-21 09:27:27)

Offline

#6 2012-05-22 23:43:41

Benedikt B
Administrator
Registriert: 2010-12-05
Beiträge: 249

Re: OSP vergisst AD-Daten

Hallo A.N.

Verwendest du bereits die 2.0 oder die 2.1 Version des OSP? Denn von 1.x auf 2.x habe ich unter anderem einige Parameter bei der AD-Integration angepasst. Ich weiß zumindest von 2 Schulen, bei denen das Problem dadurch gelöst wurde.

Wenn es nicht an der Version liegt, kann ich gerne einige weitere Dinge beschreiben, die du überprüfen kannst. Insbesondere würde auch die Ausgabe von

sudo tail -n 50 /var/log/samba/log.winbindd
sudo tail -n 50 /var/log/samba/log.smbd
sudo tail -n 50 /var/log/samba/log.nmbd

bei der Fehlersuche helfen.

Viele Grüße

Benedikt

Offline

#7 2012-06-04 21:01:18

Benedikt B
Administrator
Registriert: 2010-12-05
Beiträge: 249

Re: OSP vergisst AD-Daten

Hallo A.N.

Dass Problem mit der A.D. Integration kann evtl. auch an einem Bug im AD-Integrationsskript in der 2.01 Version gelegen sein. Solltest du die 2.01 Version installiert haben, oder installieren wollen, fuehre nach der Konfiguration ein

sudo osp-update -a

durch und starte dann das AD-Integrationsskript mit

sudo osp-adintegration -s

Ich werde auch bald neue Installationsimages rausbringen, die dieses Problem beheben.

Sollte es aber daran nicht liegen, koennen im Augenblick nur die Log-Files weiterhelfen.

Viele Gruesse

B. Brandt

Offline

Fußzeile des Forums

Powered by FluxBB